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About the ABBYY FlexiCapture Connector for UiPath
ABBYY FlexiCapture 12 enables users to perform high-quality full-text recognition, classify documents,

detect fields and capture their data, and convert files into various formats (e.g. searchable PDF).

ABBYY FlexiCapture Integration Solution for UiPath is intended for sending document files from UiPath

to ABBYY FlexiCapture and loading document files and captured data into the UiPath robotic process

automation system.

ABBYY FlexiCapture Integration Solution for UiPath is provided as two separate solutions, a Multi-Task

Package and a Single-Task Package.

The Multi-Task Package is intended for concurrent processing of multiple documents. Each activity in

this solution is used for some type of interaction with ABBYY FlexiCapture.

The Single-Task Package is intended for processing documents one at a time. The program will start on

a new document only after the current document has been processed.

System requirements
UiPath side:

· UiPath Enterprise Edition 19.4.4 or Community Edition 19.7.0;

· Microsoft .NET Framework 4.6.1.

ABBYY FlexiCapture side:

· ABBYY FlexiCapture 12.0.2.3104 Distributed or ABBYY FlexiCapture Cloud;

· Microsoft .NET Framework 4.6.1.

Important! To be able to send documents from UiPath to ABBYY FlexiCapture, you need to open the
following port in the firewall to the ABBYY FlexiCapture Application Server: port 80 (if HTTP is used) or
port 443 (if HTTPS is used).

Multi-Task Package
Architecture

The ABBYY FlexiCapture 12 multi-task integration solution for UiPath comprises the following

components:

· UiPath Activity Package.

· UiPath Processes.

· UiPath Queues, which is required in order for the default processes to function properly. The

ABBYY FlexiCapture 12 multi-task integration solution for UiPath requires the addition of the

following queues: Monitor Queue, Verifier Queue, and Fetcher Queue. Queues are used for

storing the IDs of the batches with which the processes are currently working.

· UiPath Assets/Credential, which makes setting up a ABBYY FlexiCapture server connection

easier. These values are used by all of the processes. The ABBYY FlexiCapture 12 multi-task

integration solution for UiPath requires the addition of the FlexiCapture Credentials credential
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and the following assets: FlexiCapture Server Address, FlexiCapture Company, FlexiCapture

Project Name.

UiPath Activity Package

The Abbyy.UiPath.FlexiCapture.MultiTaskActivities.nupkg activities package offers all the

functionality you need to worki with ABBYY FlexiCapture 12. It includes the following activities for working

with ABBYY FlexiCapture:

· FlexiCapture Project Scope

· Create Batch

· Get Batch Stage

· Get Batch Verification URLs

· Fetch Batch Result

FlexiCapture Project Scope

This activity is used for initializing the other activities in the package through the ABBYY FlexiCapture 12

connection settings. These other activities are placed in the child activity area to give them access to the

ABBYY FlexiCapture connection settings.

The following is a list of activity parameters that are inherited by child activities:
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Category Display Name Type Description

FlexiCapture Connection

Settings

Server URL Uri Server address (without

the tenant)

FlexiCapture Connection

Settings

Company String Server tenant name

(optional)

FlexiCapture Connection

Settings

Username String User name

FlexiCapture Connection

Settings

Password SecureString User password

FlexiCapture Connection

Settings

Project name String Project name

Proxy Settings (optional) Server URL Uri Proxy server address

Proxy Settings (optional) Username String User name

Proxy Settings (optional) Password SecureString User password

The FlexiCapture Project Scope designer allows you to manage connection settings and child activities:

If you are using a proxy:

1. Create the following variables:

§ A variable of type Uri named ProxyAddress with the following value:
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New UriBuilder ("http://proxyserver:8080").Uri. In place of "http://proxyserver:8080",

specify the address and port of the proxy server.

§ A variable of type NetworkCredential named ProxyCredential with the following value:

New System.Net.NetworkCredential("proxyuser", "proxypass"). In place of "proxyuser"

and "proxypass", specify the proxy credentials separated by a comma. Create this variable if

your proxy uses Basic authentication.

2. Use the variables created in step 1 to pass the proxy connection settings to the FlexiCapture

Project Scope activity (click FlexiCapture Project Scope → Proxy Settings (optional)).

Depending on the authentication type required by the proxy, do the following:

§ If a transparent proxy is used, in the Server URL field, pass the proxy server address and port

as the value of the ProxyAddress variable and leave the Username and Password fields

empty.

§ If the proxy uses NTLM authentication, in the Server URL field, pass the proxy server address

and port as the value of the ProxyAddress variable and leave the Username and Password

fields empty. The credentials under which the UiPath process is running will be used.

§ If the proxy uses Basic authentication, in the Server URL field, pass the proxy server address

and port as the value of the ProxyAddress variable. In the Username and Password fields,

pass the proxy credentials as the values of the corresponding properties of the

ProxyCredential variable.

Note: These proxy server settings will be inherited by all the child activities of this Project Scope.

Create Batch

This activity is used to send files to ABBYY FlexiCapture 12 for processing. ABBYY FlexiCapture creates

a batch with a unique identifier for all documents sent by this activity. This identifier is then returned as

the Batch ID output argument.
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Activity parameters:

Category Display Name Type Description

Input Batch type name String Name of the batch type for the batch

that is being created (optional)

Input Batch registration

parameters

IEnumerable<KeyVal

uePair< String,String

>>

A collection of registration parameters

for the batch that is being created,

specified in the following format:

Registration parameter name —

Registration parameter value (optional)

Input Batch files IEnumerable<KeyVal

uePair<String,Byte[]

>>

A collection of input files for the batch

that is being created, specified in the

following format: File name — Byte

content

Output Batch ID Int32 ID of the created batch

Get Batch Stage

This activity is used to get information about the current batch stage. Values describing the batch state

can be used, for example, to group batches for processing by their current stage.

Activity parameters:
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Category Display Name Type Description

Input Batch ID Int32 Batch ID

Output Stage type Enum Processing stage type

Output Stage name String Processing stage name

Output Details String Additional information

about the state of the

batch

Get Batch Verification URLs

This activity is used to get a set of links to the ABBYY FlexiCapture Web Verification Station for batch

verification (uses the batch ID).

Activity parameters:

Category Display Name Type Description

Input Batch ID Int32 Batch ID

Output Verification URLs IEnumberable<Uri> A set of batch

verification URLs

Fetch Batch Result

This activity is used to get the batch processing results.

Activity parameters:

http://help.abbyy.com/en-us/flexicapture/12/developer/tprocessingstagetype
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Category Name Display Name Type Description

Input BatchId Batch ID Int32 Batch ID

Output BatchRegistrationP

arameters

Batch registration

parameters

IEnumerable<KeyV

aluePair<String,Stri

ng>>

Batch registration

parameter set

Output DocumentProcessi

ngResults

Document

processing results

IEnumerable<Docu

mentProcessingRe

sult>

Batch document

processing result

set

DocumentProcessingResult class properties:

Name Type Description

DocumentId Int32 Document ID

DocumentDefinition String Name of the matched document

definition

Files IEnumerable<KeyValuePair<Strin

g,Byte[]>>

Export files

UiPath Processes

The ABBYY FlexiCapture Multi-Task Package includes the following processes:

· Batch Sender

· Batch Monitor

· Batch Verifier

· Batch Fetcher

· Batch Processor – single process

Batch Sender

This process takes files from a folder and uses the Create Batch activity to send them to ABBYY

FlexiCapture 12 for processing. ABBYY FlexiCapture will create a single batch for each file it finds in that

folder. Next, the ID of the newly created batch is added to the Monitor Queue for subsequent

processing in the Batch Monitor process.

Batch Monitor

This is a constantly running process which handles items in the Monitor Queue.
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Using the Get Batch Stage activity, it gets the stage of a batch and performs the following:

· For a batch at the "Processed" stage, a new item will be added to the Fetcher Queue, after

which the item in the Monitor Queue will be marked as successfully processed.

· For a batch at the "Verification" stage, a new item will be added to the Verifier Queue and the

processing of the item in the Monitor Queue will be postponed. The element will not be added to

the Verifier Queue once again.

· If a batch is at the "Exceptions" stage (where they may be placed due to processing errors), an

item in Monitor Queue will be marked as an exception. The text of the error message will be

recorded in the "Reason" section.

· For a batch at any other stage, the processing of the Monitor Queue will be postponed.

Note: We recommend that you launch this process from UiPath Orchestrator.

Batch Verifier

This process handles items from the Verifier Queue, one item at a time. It gets verification URLs by

the ID of the batch and opens them in a browser, where the respective documents can be verified by the

verifier. Once verified, an item is marked as completed.

Batch Fetcher

This is a constantly running process which handles items from the Fetcher Queue. It accepts batch

processing results and saves the export files created for each document in a batch. Once the export

files are saved, the process marks the item as successfully processed.
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Batch Processor – single process

This process performs a full document processing procedure in ABBYY FlexiCapture: creates batches,

checks their status, gets verification URLs, and downloads the processing results. Batch Processor -

single process comprises the following processes: Batch Sender, Batch Monitor, Batch Verifier,

and Batch Fetcher.

This process does not require UiPath Orchestrator assets and queues. It can be launched from the

UiPath Studio without connecting a Robot to the Orchestrator.

Installation

Installation of the Multi-Task Package in UiPath consists of the following steps:

· activity package installation;

· process installation.

Installing the Abbyy.UiPath.FlexiCapture.MultiTaskActivities activity package

· If you are using UiPath Community, copy the Abbyy.FlexiCapture.WebApi.Client.nupkg and

Abbyy.UiPath.FlexiCapture.MultiTaskActivities.nupkg packages to the local activity feed folder

found in %localappdata%\UiPath\app-XX.X.X\Packages, where XX.X.X denotes the UiPath

version.

· If you are using UiPath Enterprise:

o open Orchestrator as an administrator and go to the Libraries tab;

o click Upload and choose the following packages to be uploaded:

Abbyy.FlexiCapture.WebApi.Client.nupkg and

Abbyy.UiPath.FlexiCapture.MultiTaskActivities.nupkg.

 

Once they have been uploaded, the packages will become accessible for all Robots connected to

Orchestrator.
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Installing UiPath processes

To install the Batch Sender, Batch Monitor, Batch Verifier, and Batch Fetcher processes, copy the

appropriate folders from the installation directory to any location on your local machine. After that, open

the processes in UiPath Studio and click Publish on the Design tab to publish them in UiPath

Orchestrator.

Note: Processes should only be launched once queues and assets have been created in
Orchestrator. For more information about launching processes, see Launching the processes.

To install the Batch Processor – single process process, copy the folder containing it to your local
machine. For more information about launching this process, see Launching Batch Processor – single
process.

Configuring and starting the components

Creating UiPath Orchestrator queues

Creating UiPath assets

Launching the Batch Sender, Batch Monitor, Batch Verifier, and Batch Fetcher processes

Launching Batch Processor – single process

Creating UiPath Orchestrator queues

To create a UiPath Orchestrator queue:

1. Open the Queues tab in Orchestrator.

2. Create three queues with the following names: Monitor Queue, Verifier Queue, and Fetcher

Queue. During the creation process, select the following options: Unique Reference: Yes and

Auto Retry: No.

Note: To modify the queue names, follow the steps outlined in Customizing queue names.
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Creating UiPath assets

UiPath Orchestrator assets and credentials are used in UiPath processes to store settings for

connecting to ABBYY FlexiCapture 12.

To create UiPath assets:

1. Log in to Orchestrator as an administrator.

2. Go to the Assets tab.

3. Create the following Text-type assets:

o FlexiCapture Server Address. Specify the ABBYY FlexiCapture Application Server address

as this asset's Value.

o FlexiCapture Company (optional) – name of the tenant (company) on the ABBYY FlexiCapture

Application Server. Create this asset if you are using FlexiCapture Cloud or a local multi-tenant

system.

o FlexiCapture Project Name. For this asset's Value, specify the name of the project that you will

be using to process documents. For more information about setting up and uploading a project to

a server, see Configuring a FlexiCapture project.
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4. Create the credentials. To do this, create a Credential-type asset and name it FlexiCapture

Credentials. Fill out the Username and Password fields with the ABBYY FlexiCapture user

name and password.

Note: The user specified in the ABBYY FlexiCapture asset should either have both the Scanning
Operator and the Verification operator roles, or the Administrator role. Access rights must be set up by a
ABBYY FlexiCapture administrator using the Administration and Monitoring Console. For more
information about setting up access rights, see the Administration and Monitoring Console help guide.

Launching the Batch Sender, Batch Monitor, Batch Verifier, and Batch Fetcher

processes

Before launching the processes, make sure that the appropriate queues and assets have been created

in Orchestrator and that the FlexiCapture project has been uploaded to the ABBYY FlexiCapture

Application Server and set up correctly.

At least two UiPath Robots will also be needed to launch the processes. One of the robots should

always be running the Batch Monitor process, while the other robot (or several others) should be used

to launch the Batch Sender, Batch Verifier, and Batch Fetcher processes.

You can create robots on different machines. Or you can create robots on a single machine that has the

Windows Server Operating System.

1. Create two standard robots, one of which will be of the Unattended type.

http://help.abbyy.com/en-us/flexicapture/12/monitoring_console/users
https://robot.uipath.com/docs/setting-up-windows-server-for-high-density-robots
https://orchestrator.uipath.com/docs/managing-robots
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2. Publish the Batch Monitor, Batch Sender, Batch Verifier, and Batch Fetcher processes to

Orchestrator.

3. For each published package, deploy the process in the same environment, of which the created

robots are part.

4. Go to the Jobs tab in Orchestrator. Create a new Job for the Batch Monitor process and set it

up to execute an Unattended-type robot.

https://studio.uipath.com/docs/about-publishing-automation-projects
https://orchestrator.uipath.com/docs/managing-processes
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The Batch Monitor process will be launched using the specified robot and its Job will now have

the Running status. To see the process logs, go to More Actions → View Logs.

5. Next, launch Batch Sender on a different robot. This process will send files from the selected

folder to ABBYY FlexiCapture for processing. You can also launch Batch Sender using the

Orchestrator Jobs tab, UiPath Studio, or the system tray of the robot's machine.

6. Wait until document processing has finished. If the batches have been processed successfully,

the status of the transaction in the Monitor Queue will be changed to Successful and new

transactions will appear in the Batch Fetcher queue.

7. Launch the Batch Fetcher process to download the batch processing results. The status of the

transaction in Fetcher Queue will be changed to Successful.

8. If the sent batch reaches the verification stage in ABBYY FlexiCapture, the Batch Monitor

process will create a transaction using the batch's ID in Verifier Queue. If transactions with the

New status exist in this queue, launch the Batch Verifier process to get a batch verification URL.

After that, verify the document data and complete the verification task.

After that, the batches will be exported and moved to the Processed stage. Batch Monitor will

change the status of the appropriate transactions in Monitor Queue to Successful and add new

transactions to Fetcher Queue.

To download the processing results for verified batches, launch the Batch Fetcher process for

each Fetcher Queue transaction.

https://robot.uipath.com/docs/the-user-interface
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Launching Batch Processor – single process

Before launching the process, make sure that the FlexiCapture project has been uploaded to the ABBYY

FlexiCapture Application Server and set up correctly. The InvoiceDemoProject_Multitask test project

can also be uploaded to the server from the connector installation directory located in \Multi-task

package\Samples\FlexiCapture Projects.

1. Open Batch Processor – single process in UiPath Studio.

2. Open the Variables tab.

3. Specify the settings for connecting to ABBYY FlexiCapture using the following variables:

FlexiCaptureServerUrl, FlexiCaptureCompany, FlexiCaptureUsername, FlexiCapturePassword,

FlexiCaptureProject, and FlexiCaptureBatchType.

Note: For the InvoiceDemoProject_Multitask project, the following can be specified in the
FlexiCaptureBatchType variable:

o The Unattended service value — for demonstrating a verification-less processing scenario.

o The Attended service value — for demonstrating a processing scenario with verification.

4. Create a new folder on your local machine and copy several images from the ABBYY

FlexiCapture project's Images folder to this new folder.

5. Go to the Design tab in UiPath Studio and click Run.

6. Once the process has been launched, specify the folder where you have placed the image

samples. Files from that folder will be sent to ABBYY FlexiCapture for processing.

7. Wait until file recognition has finished. Next, do the following (depending on the chosen scenario):

o Choose a folder where the processing results will be saved.

or

o Complete the verification, and after that choose a folder where the processing results will be

saved.

Usage scenarios

The ABBYY FlexiCapture Multi-Task Package for UiPath can typically be used in the following scenarios:

· ABBYY FlexiCapture as unattended service.

· ABBYY FlexiCapture as attended service.

ABBYY FlexiCapture as an unattended service

In this scenario, ABBYY FlexiCapture processes documents without human assistance and recognition

results are not verified by human operators.
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At least one instance of the Batch Monitor process is constantly running. Batch Sender process

sends files to ABBYY FlexiCapture for processing. The Batch Fetcher process saves the exported files

of batches that have been processed successfully.

The Monitor Queue is used for transferring batch IDs between the Batch Sender and Batch Monitor

processes, and the Fetcher Queue is used for transferring batch IDs between the Batch Monitor and

Batch Fetcher processes.
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ABBYY FlexiCapture as an attended service

In this scenario, a human operator verifies documents on the Web Verification Station.

This scenario extends the "ABBYY FlexiCapture as unattended service" scenario with a Batch Verifier

process and a Verifier Queue.

Customizing processes in UiPath

Customizing timeouts in the Batch Monitor process

Customizing queue names

Customizing assets and credential names

Customizing timeouts in the Batch Monitor process

The following TimeSpan-type variables are used for specifying the timeout length in the Batch Monitor

process:
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Variable name Purpose Default value

EmptyQueueTimeoutDuration Length of time for which the next

attempt to get a transaction from

the  Monitor Queue will be

postponed when no documents

are present in the queue

15 seconds

VerificationStagePostpone Length of time for which the next

batch stage check will be

postponed for the current

transaction if the batch was in the

Verification stage at the time of

the check

2 minutes

OtherStagePostpone Length of time for which the next

batch stage check will be

postponed for the current

transaction if the batch is not in

any of the following stages: 

Processed, Exceptions,

Verification

1 minutes

Increasing the VerificationStagePostpone and OtherStagePostpone timeout values can increase

the total processed transaction volume.

To modify the timeout values:

1. Open the Batch Monitor process in UiPath Studio, navigate to the State Machine area and

expand the Variables pane.

2. Modify the value of the EmptyQueueTimeoutDuration variable to decrease or increase the time

between attempts to get a transaction if the queue is empty.

3. If the Batch Monitor process cannot check the whole queue in time due to a large number of

delayed transactions, increase the values of the VerificationStagePostpone and

OtherStagePostpone variables.
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4. Once the changes have been made, publish the process to Orchestrator again.

Customizing queue names

By default, queues should have the following names:

· Monitor Queue

· Verifier Queue

· Fetcher Queue

If the need arises, queues with non-default names can be created by specifying the appropriate non-

default names inside the process variables.

The Batch Sender process

For this process, specify the name of the queue to which identifiers of the created batches will be

added.

1. Open the process in UiPath Studio and expand the Variables tab.

2. Navigate to the Flowchart area and enter the new queue name in the Default column for the

MonitorQueueName variable.



Snippet source Guide_header.xml not found!

The Batch Monitor process

For this process, specify the names of all 3 utilized queues.

1. Open the process in UiPath Studio and navigate to the State Machine area.

2. Expand the Variables pane.

3. Enter the new queue names in the Default column for the MonitorQueueName,

VerifierQueueName, and FetcherQueueName variables.
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The Batch Verifier process

For this process, specify the name of the queue that will store identifiers of batches awaiting verification.

1. Open the process in UiPath Studio and navigate to the Flowchart area.

2. Expand the Variables pane.

3. Enter the new queue name in the Default column for the VerifierQueueName variable.
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The Batch Fetcher process

For this process, specify the name of the queue where identifiers of successfully processed batches will

be stored. After this, batch processing results will start to be downloaded using the Batch Fetcher

process.

1. Open the process in UiPath Studio and expand the Variables pane.

2. Enter the new queue name in the Default column for the FetcherQueueName variable.
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Once the changes have been made, publish all modified processes to Orchestrator again.

Customizing assets and credential names

By default, the orchestrator assets have the following names:

· FlexiCapture Server Address

· FlexiCapture Company

· FlexiCapture Project Name

· FlexiCapture Credentials

If the need arises, assets with non-default names can be created. To do this, open all processes in

UiPath Studio (Batch Sender, Batch Monitor, Batch Verifier, and Batch Fetcher) and modify the names

of their assets.

The Batch Sender process

1. Open the process in UiPath Studio and navigate to the Acquire connection settings from

Orchestrator area.

2. Expand the Variables pane.

3. Enter new asset names in the Default column for each of the following variables:

AssetNameServerUrl, AssetNameCompany, AssetNameCredentials, and

AssetNameProject.
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The Batch Monitor process

1. Open the process in UiPath Studio and navigate to the State Machine area. Select Initialization

→ Acquire connection settings from Orchestrator.

2. Expand the Variables tab.

3. Enter new asset names in the Default column for each of the following variables:

AssetNameServerUrl, AssetNameCompany, AssetNameCredentials, and

AssetNameProject.
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The Batch Verifier process

1. Open the process in UiPath Studio and navigate to the Acquire connection settings from

Orchestrator area.

2. Expand the Variables tab.

3. Enter new asset names in the Default column for each of the following variables:

AssetNameServerUrl, AssetNameCompany, AssetNameCredentials, and

AssetNameProject.
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The Batch Fetcher process

1. Open the process in UiPath Studio and navigate to the Acquire connection settings from

Orchestrator area.

2. Expand the Variables tab.

3. Enter new asset names in the Default column for each of the following variables:

AssetNameServerUrl, AssetNameCompany, AssetNameCredentials, and

AssetNameProject.

Once the changes have been made, publish all modified processes to Orchestrator again.

Configuring ABBYY FlexiCapture project

In ABBYY FlexiCapture, documents are processed within projects. ABBYY FlexiCapture will identify the

type of each document and apply the appropriate Document Definition that has been prepared

specifically for that type. Each Document Definition includes one or more export profiles to be used for

exporting document images and data. If you are not familiar with the aforementioned concepts, please

refer to the ABBYY FlexiCapture documentation, where you will find a detailed description of the capture

process.

Before you start configuring your project, please make sure that you have the following software

installed:

· ABBYY FlexiCapture 12 Project Setup Station (required if you are using ABBYY FlexiCapture

Distributed Edition or ABBYY FlexiCapture Cloud).

If you already have an ABBYY FlexiCapture project for which you need to set up data export to UiPath,

open that project. Otherwise, you will need to create a project. Launch the Project Setup Station and in

the Open Project dialog box click:

· Create New... to create a new project.

· Browse... to open an existing project stored on your local drive.

· Browse from Server...  to a open a project that you earlier uploaded to the ABBYY FlexiCapture

Application Server.

http://help.abbyy.com/
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Next, if you have opened your project locally, you need to upload it to the ABBYY FlexiCapture

Application Server:

1. Click File → Upload Project to Server....

2. In the Upload Project to Application Server dialog box, specify the address of the server, the

protocol to be used, and your credentials.

3. If you are using ABBYY FlexiCapture Cloud, complete the URL field, specifying one of the

following three FlexiCapture Cloud instances (you should specify the instance that your company

is registered in):

· https://europe.flexicapture.com

· https://australia.flexicapture.com

· https://usa.flexicapture.com

In the Tenant name field specify the name of your company, select the Use server

authentication option, and enter your credentials.

4. Click Test Connection to make sure that you have entered the correct data.

5. Click OK to upload project to Application Server.

Note: When uploading a project to the cloud or when opening a project from the cloud, the following
error may occur: "Application server version is not compatible." If you see this error, the version of your
Project Setup Station does not match the version of the cloud-based Application Server. To obtain a
compatible version of ABBYY FlexiCapture, please contact the ABBYY sales office in your region (see
https://www.abbyy.com/contacts).

6. When you see the "Operation completed" message, click Close. In the next dialog box, click Yes

to open the uploaded project from the server.

https://www.abbyy.com/contacts
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Verify that the ABBYY FlexiCapture Processing Server is running, and that the Processing Stations have

been added, set up, and started. To do this, launch the Processing Server Monitor by selecting Start →

All Programs → ABBYY FlexiCapture 12 Servers → Processing Server. Both the server and the

stations should have the "Started" status:

For more details about configuring ABBYY FlexiCapture Processing Server, see ABBYY FlexiCapture

Online help.

Now you need to configure your project, i.e. to create an export profile in your Document Definition and

to select the appropriate type of workflow.

Note: You can use a predefined project to process invoices. The InvoiceDemoProject_Multitask.zip
archive containing project files and sample images can be found in the connector installation folder
located in \Multi-task package\Samples\FlexiCapture Projects. Unpack the archive, open the project
in ABBYY FlexiCapture Project Setup Station and upload it to the server by following the instructions
above.

Creating an export profile

To configure an export profile:

1. In the ABBYY FlexiCapture Project Setup Station click Project → Document Definitions... to

open the list of Document Definitions available for the project. Select the Document Definition for

which you want to specify new export settings, and click Edit....

2. Click Document Definition → Export Settings....

3. Click the Add... button to start the export profile creation wizard.

http://help.abbyy.com/en-us/flexicapture/12/distributed_administrator/procserver
http://help.abbyy.com/en-us/flexicapture/12/distributed_administrator/procserver
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4. In the Select the Type of Destination step, select Export to data files from the Type drop-

down list, select the Critical option below, select the Errors are irrelevant item from the

Document condition drop-down list, and click Next.

5. In the Export Data to Files step, make sure the Export path field is empty and specify a file

name template. Click Next.

6. In the Data File Format step, select the required output format in the File type field, and click

Next.

7. Provide a name for your newly created export profile and click Finish.

8.  In the Export Settings dialog box, check the Enabled box for the newly created export profile.

Click Apply, then click OK.
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9. Save and close the Document Definition editor. Next, click the Publish button to publish your

Document Definition.

Configuring an ABBYY FlexiCapture workflow

To configure an ABBYY FlexiCapture workflow:

1. Click Project → Project Properties... and make sure that the Export root path on the General

tab is left empty.

2. Open the Workflow tab. Depending on your usage scenario, select the appropriate workflow type:

§ If you intend to process documents in unattended mode, select Unattended from the Schema

drop-down list and click OK.

§ If you need recognition results to be verified prior to export, select Advanced from the Schema

drop-down list. Next select Verification and click the Edit… button. In the Workflow Stage

Properties dialog box, select Wait for all documents of a batch and Enable web stations.
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Single-Task Package
Architecture

The ABBYY FlexiCapture 12 single-task integration solution for UiPath comprises:

· Abbyy.Activities.UiPath.FlexiCaptureActivities NuGet package containing the Capture Data

activity. Capture Data activity is used for sending files to ABBYY FlexiCapture 12 and getting the

processing results in synchronous mode.

Note:  The activity only works with files containing one document each (i.e. each document must be
placed in a separate file).

· FlexiCapture Export Connector for UiPath. It creates a transaction in the queue of the

Orchestrator at the export stage, in which it stores the image file and metadata.
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Usage scenarios

The ABBYY FlexiCapture single-task integration solution for UiPath can typically be used in the following

three scenarios:

1. FlexiCapture as an unattended service (UiPath - FlexiCapture - UiPath); no verification is

required.

The UiPath process in which the activity is running sends the file to the FlexiCapture and receives the

processing results in synchronous mode.The FlexiCapture project requires unattended workflow in

batch type properties and Export to data files (XML) export profile in the document definition properties. In

this scenario, files received by ABBYY FlexiCapture 12 do not require verification, so once the

recognition is completed, they go directly to the export stage.

2. FlexiCapture as an attended service (UiPath - FlexiCapture - Verification - UiPath).

The UiPath process in which the activity is running sends the file to the FlexiCapture and receives only a

URL linking to the document verification page. In the UiPath process, for example, you can configure the

sending of this link to the verification operator by email. When the verification is complete, the document

goes to the export stage, where the script export profile applies to it. As a result of the export, a new

transaction is created in the specified queue of UiPath Orchestrator. Transaction contains image file and

recognized metadata. All data from the transaction can be extracted in a separate UiPath process in

which the user can configure their further processing as it's required in his business scenario.

3. FlexiCapture as input (FlexiCapture Mobile/Scanning Station - FlexiCapture - Verification (if

required) - UiPath).

Image files are imported to FlexiCapture using a mobile client or from a Scanning Station. Documents

are verified if it's necessary. At the export stage the document uses the script export profile. As a result

of the export, a new transaction is created in the specified queue of UiPath Orchestrator. The transaction

contains an image file and extracted metadata. The further process of working with the transaction is

similar to "FlexiCapture as an attended service" scenario.

FlexiCapture as an unattended service

To configure this scenario, complete the following steps:

1. On the UiPath side, install and configure the Capture Data activity.

2. On the ABBYY FlexiCapture side, configure a FlexiCapture project:

o Configure the XML export profile in the Document Definition.

o Configure the document processing settings.

Configuring the document processing settings

Document processing is configured for a batch type. To configure document processing for the

"Default" batch type, click  Project→ Project properties. To configure document processing for a

specific batch type, click Project→ Batch types→ Edit....

Click the Image Processing tab, and set the Create document for each image file option. For each

image file received at the input of activity, one document will be created in the batch.
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Then go to the Workflow tab. Select Schema: Unattended. This scheme provides the possibility of

automatic processing without operator involvement. Save the changes.

FlexiCapture as an attended service

To configure this scenario, complete the following steps:

1. On the UiPath side, install and configure the Capture Data activity.

2. On the ABBYY FlexiCapture side, configure a FlexiCapture project:

o Create a Standard XML export profile.

o Create a script export profile in the Document Definition using the following sample script:

UiPath - ExportScript - Configure by script (Attended service).cs.

o Configure the document processing settings.

Configuring the document processing settings

The ABBYY FlexiCapture workflow can be configured either for each batch type separately or for the

"Default" batch type. To configure the workflow:

1. On the Project Setup Station, either click Project → Project Properties… (if you want to

configure the "Default" batch type) or click Project → Batch types → Edit... (if you want to

configure a particular batch type).

2. On the Workflow tab of the Project Name Properties dialog box, change the workflow schema

from Simple to Advanced.

3. On the same tab, select the verification stage and click the Edit.... button to open the Workflow

Stage Properties dialog box and on the General tab, select the Enable web stations option.

Click OK to save the changes.

4. Return to the Workflow tab in the Project Name Properties dialog box and click the Stage...

button to add a new stage. In the Create Processing Stage dialog box, select Automatic and

click OK.

5. In the Workflow Stage Properties dialog box, provide a name for the new stage, make sure that

the Wait for all documents of a batch option is selected, and select the Linked to previous

option.

6. On the Script tab, select Document processing from the Type drop-down list.

7. On the same tab, click the Edit script… button and type in the following script code:

Document.Properties.Set("WasVerified", bool.TrueString);

This script adds a registration parameter to each processed document that indicates whether or

not the given document has gone through the verification stage.

8. On the Entry Conditions tab, select Under these conditions and click the Rule... button to

specify a condition when documents should be sent to the newly created stage.

9. In the Rule Settings dialog box, provide a name for the new rule in the Name field. Then from the

Condition type drop-down list, select Script, click the Script… button and type in the following

script code:
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Result.CheckSucceeded = (Document.StageInfo.StageName == "Verification Postprocessing" ||

Document.StageInfo.StageName == "Verification");

This script sets the input condition for the new stage: If a document arrives from the verification

stage, it will be admitted into the new stage and will be provided with a "WasVerified" registration

parameter. 

10.Save the newly configured rule and the new script stage. 

Important! The new script stage must immediately follow the verification stage.

FlexiCapture as input

To configure this scenario, on the ABBYY FlexiCapture side, configure a FlexiCapture project:

1. Install an export connector (add assemblies to the document definition).

2. Create a script export profile.

Installing, configuring, and starting the Capture Data activity in

UiPath

The Abbyy.Activities.UiPath.FlexiCaptureActivities activity package also includes the Capture Data

activity. This activity operates on UiPath side inside of user-defined workflow. Activity takes an input file,

sends it to the FlexiCapture Application Server and waits for up to 5 minutes for the processing results.

Installing an activity package can entail the following:

· installing a package so that it is used by Robots to complete an existing process;

· installing a package in UiPath Studio to create a new process.

Installing the Abbyy.Activities.UiPath.FlexiCaptureActivities activity

package

Installing an activity package for working with an existing UiPath process

All UiPath processes consist of various activities. When a process is launched by a Robot or opened in

UiPath Studio, a search is carried out in the available activity feeds for the relevant activities, which are

then downloaded. 

To open a sample ABBYY FlexiCapture 12 Processor process, place the

A.FlexiCapture.WebApi.Client.nupkg and Abbyy.Activities.UiPath.FlexiCaptureActivities.nupkg

packages in a Robot-accessible Activity Feed. To do this:

· Place them in the %LocalAppData%\UiPath\app-xx.x.x\Packages folder if you are using UiPath

Community Edition (where xx.x.x denotes the UiPath version number).

· Place them in the C:\Program Files (x86)\UiPath\Studio\Packages folder if you are using UiPath

Enterpise Edition.

 Note: To find out the path to the Robot's local feed, open UiPath Studio and open the Settings tab.

Then, select Local in Manage Sources.
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To decrease the time needed to update a package for all Robots, place it in the Orchestrator's Activity

Feed (in this case, the packages will become available for all Robots connected to Orchestrator). To do

this:

· If you are using UiPath Community Edition, go to the cloud Orchestrator and select Processes →

Packages. Then click Upload a upload the Abbyy.FlexiCapture.WebApi.Client.nupkg and

Abbyy.Activities.UiPath.FlexiCaptureActivities.nupkg packages one after another.

· If you are using UiPath Enterpise Edition, copy the packages to the Orchestrator's Activity Feed (by

default, it is located in C:\Program Files (x86)\UiPath\Orchestrator\NuGetPackages\Activities

on a machine that has Orchestrator installed) or download the packages on the Libraries tab in

the Orchestrator web application.

For more information about Activities Feeds, see UiPath documentation.

Adding an activity package to a new process

To use the Capture Data activity in a new process or add it to an existing one, you need to include the

Abbyy.Activities.UiPath.FlexiCaptureActivities.nupkg activity package in the dependencies of the

process. To do this:

1. Open an existing process in UiPath Studio and click Manage Packages.

https://robot.uipath.com/docs/about-the-activities-feed
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2. Select Settings and find the local Source in the Default package sources list.

3. Copy the Abbyy.FlexiCapture.WebApi.Client.nupkg and

Abbyy.Activities.UiPath.FlexiCaptureActivities.nupkg packages to the folder, the path to

which is specified in Default local package source. Alternatively, place these packages in any

other available source from the list.

4. Go to Manage Packages and navigate to All packages → Local. Then, select

Abbyy.Activities.UiPath.FlexiCaptureActivities in the activity list.
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5. Click Install, then click Save.

After that, the Capture Data activity will appear in the available activies list:

Setting up the Capture Data activity

To use the activity in a UiPath process, you will need to complete the following steps:

1. Configure the FlexiCapture project on the ABBYY FlexiCapture server depending on your usage

scenario.
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2. Create a process in UiPath Studio or use the sample UiPath project named ABBYY FlexiCapture

12 Processor, which is included in the distribution package.

3. Configure the ABBYY FlexiCapture activity.

Note: After you have set up the ABBYY FlexiCapture project and the UiPath process activity, you can
launch the process in debug mode for debugging.

4. Publish the UiPath process to Orchestrator for further use by the Robots. Refer to the UiPath

Orchestrator Guide for information on how to work with packages and how to set up Robots.

Configuring Capture Data activity properties

You can add an activity to the process by dragging it from the UiPath Studio Activity panel. After the

activity is added to the process, you need to fill in its fields in the properties panel located in the right-

hand part of the UiPath Studio window.

· Use the Input fields for transferring an image file and its name to the activity:

o FileContent is a file to be sent to ABBYY FlexiCapture as a byte array (this field accepts values of

type System.Byte[]).

o FileName is the name of a file to be sent to ABBYY FlexiCapture (this field accepts values of type

String).

o The BatchRegistrationParameters field allows you to specify user registration parameters for a

batch when sending files to ABBYY FlexiCapture. The values of these registration parameters

can be used to specify the names of export files (when exporting from ABBYY FlexiCapture). The

field accepts values of type IEnumerable<KeyValuePair<string, string>>. The

Dictionary<String, String> class is recommended for passing the registration

parameters. Dictionary must be initialized. The field value may look like this:

new Dictionary(Of String, String) from {{"Key", "Value"}, {"Key1",

"Value1"}}.

This field is optional. Leave this field empty if you do not need to specify any registration

parameters. Registration parameter values can be used, for example, for naming export files in

ABBYY FlexiCapture.

· Output fields allow you to specify variables in which the activity will save results:

o Fields is an array of ‘field name, field value’ pairs containing a list of document fields. This field

accepts values of type IEnumerable<KeyValuePair<String, String>>.

Note: Fields will only be received if the resulting files include an XML file. An XML export profile must be
configured for the Document Definition in the ABBYY FlexiCapture project.

o Files is an array of ‘file name, file as byte array’ pairs containing all the files generated as a result

of processing a source file in ABBYY FlexiCapture (e.g. a source file converted to searchable

PDF, files with signature images, files with captured data, etc., depending on the export settings

specified in the ABBYY FlexiCapture project). This field accepts values of type

IEnumerable<KeyValuePair<String, Byte[]>>.

https://studio.uipath.com/docs/about-automation-projects
https://orchestrator.uipath.com/docs/about-packages
https://orchestrator.uipath.com/docs/about-robots
http://help.abbyy.com/en-us/flexicapture/12/standalone_administrator/reg_params
http://help.abbyy.com/en-us/flexicapture/12/standalone_administrator/reg_params
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o VerificationUrl is a link that opens a document processing task on the ABBYY FlexiCapture Web

Verification Station, where the user can verify the captured data. This field accepts values of type

String.

Note: An activity returns a URL for which Windows authentication is required. If you plan to send this
URL to a verification operator, make sure that the corresponding ABBYY FlexiCapture account is
registered on the ABBYY FlexiCapture server.

· The FlexiCapture Connection Settings section contains the settings required to connect to the

ABBYY FlexiCapture server. You will need to provide the server address and the credentials of the

account that will be used to connect to the server. Click Test Connection to check if the

connection has been successfully established. Then specify the project and batch type that will

accept files from the UiPath workflow process. If you are using ABBYY FlexiCapture Cloud or a

local multi-tenant system, specify your company (tenant) name. The values for these parameters

can be either be specified using a VB expression enclosed in quotes, or passed as variables of

type String.

Note: The ABBYY FlexiCapture user must have either a) the role of Administrator or b) the role of
Scanning Operator (to send documents) and the role of Verification Operator (to receive URLs linking to
document verification pages on the ABBYY FlexiCapture 12 Web Verification Station) for the given
project and batch type. To set up user permissions, use the Administration and Monitoring Console.

· Open the activity properties and navigate to Common. Here, you can set a custom timeout (in

milliseconds) for awaiting ABBYY FlexiCapture processing results. When the specified time period

expires, the activity will throw an exception. The default timeout value is 300,000 milliseconds.

http://help.abbyy.com/en-us/flexicapture/12/monitoring_console/permissions
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· If you are using a proxy, fill in the Server URL, Username, and Password fields in the Proxy

Settings (optional) section.

o If a transparent proxy is used, specify the server address and port in the Server URL field and

leave the Username and Password fields empty.

o If the proxy uses NTLM authentication, specify the server address and port in the Server URL

field and leave the Username and Password fields empty. The credentials under which the

UiPath process is running will be used.

o If the proxy uses Basic authentication, specify the server address and port in the Server URL

field and fill in the Username and Password fields.

A sample UiPath process – using the Capture Data activity

The ABBYY FlexiCapture Connector for UiPath includes a sample UiPath process named ABBYY

FlexiCapture 12 Processor. This process can be found in the \Single-task package\Samples\UiPath

Sample Processes folder of the distribution package. It demonstrates how you can use the Capture

Data activity. You can open this project in UiPath Studio for reviewing and editing.

The process prompts the user to select a folder with files and an output folder where to save the results,

sends each file from the folder to ABBYY FlexiCapture, waits for up to 5 minutes for the files to be

processed, and receives:

· the resulting files from ABBYY FlexiCapture, which may be a document file in a format specified by

the user (e.g. a searchable PDF document), a data file (e.g. a CSV file), files with image fields (e.g.

signature images), etc. These files will be saved to the previously selected output folder. These

results can only be received if export to data files is configured for the Document Definition.

· a list of captured fields and their values. The process creates a text document in the output folder

and records the received fields and their values in this text document.

· a URL linking to the document verification page on the ABBYY FlexiCapture 12 Web Verification

Station. For a document that requires verification, a URL linking to the document verification page

is returned to the process. The process creates a TXT document in the output folder and records

the URL linking to the document verification page. Then it opens the URL in the browser.

Note:  Please make sure that the Enable web stations option is enabled for the verification stage in
the ABBYY FlexiCapture workflow.

Before starting the process, make sure that the FlexiCapture Project has been configured. Then in the

Processing Files cycle, select the Capture Data activity. The Properties panel in UiPath Studio will
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display the activity properties. Next, specify the settings to be used to connect to the ABBYY

FlexiCapture Application server and choose the appropriate project and batch type on the server. These

settings can be specified either in the Settings group in the activity properties or in the activity form in

the workspace. You can specify the values explicitly using a VB expression enclosed in quotes or store

them using UiPath variables.

Place the images of documents in a folder on the disk. For testing, you can start the process from

UiPath Studio by clicking Design→ Run (F5). Also, the process can be published in Orchestrator and

launched by the Robot in the specified environment. After selecting the input and output folders, wait for

the processing results to be saved to the output folder.

Configuring ABBYY FlexiCapture project

Before you can start setting up the project, you need to upload it to the ABBYY FlexiCapture Application

Server.

Open the project in Project Setup Station. Click the "Upload project to Server..." icon on the toolbar.

Specify the Application Server address and credentials to connect, click OK, and wait until the project is

uploaded to the server.

Note:  If you are working with ABBYY FlexiCapture Cloud, you will also need the Project Setup Station
desktop application to configure the project. For more information about the steps for uploading a project
to the FlexiCapture Cloud server, see Configuring ABBYY FlexiCapture project for a Multi-Task package.

You can learn more about each scenario using the preconfigured sample project named

InvoiceDemoProject_Singletask (you can find this project in the \Single-task

package\Samples\FlexiCapture Projects folder in the connector distribution package).

On the FlexiCapture Project Setup Station, open the sample InvoiceDemoProject_Singletask and click

Upload Project to Server. There are three types of batch in the project. Each batch type is intended to

process documents in one of the usage scenarios. The export settings are specified in the "European

Invoice" Document Definition. You will need to edit the script export profile, specifying your connection

settings for UiPath Orchestrator and the queue name.

Verify that ABBYY FlexiCapture Processing Server is running and that Processing Stations have been

added, set up, and started. To do this, launch the Processing Server Monitor by selecting Start → All

Programs → ABBYY FlexiCapture 12 Servers → Processing Server. Both the server and the

stations should have the Started status:
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For more information about configuring ABBYY FlexiCapture Processing Server, see ABBYY

FlexiCapture Online help.

FlexiCapture Export Connector installation

The ABBYY FlexiCapture Export Connector for UiPath is a set of libraries running on the ABBYY

FlexiCapture 12 side. These libraries allow exporting data from ABBYY FlexiCapture to UiPath. 

Component Description

DmsConnector.dll An assembly of models and abstractions that are

common to different types of connectors.

AfcDmsConnector.dll This library receives as input objects specific to

ABBYY FlexiCapture, converts them into an

internal representation, and sends the converted

result to UiPath.

UiPathConnector.dll This library contains the connector for UiPath. It

sends processing results from ABBYY

FlexiCapture to the UiPath Orchestrator.

Newtonsoft.Json.dll Framework for working with JSON strings.

Adding the assemblies to a Document Definition

Before setting up document export, you must add the assemblies to your ABBYY FlexiCapture project.

To add the assemblies, please complete the following steps:

1. Open the ABBYY FlexiCapture Project Setup Station and open the project.

2. Click Project → Document Definitions... to open the list of Document Definitions available for

the project, select the Document Definition for which you want to specify new export settings, and

click Edit....

3. Click Document Definition → Document Definition Properties... to open the properties of the

Document Definition and then click the .Net References tab.

4. Click the Add... button. In the Add Assembly dialog box, select Attached file from the Type drop-

down list and browse for the AfcDmsConnector.dll, DmsConnector.dll, UiPathConnector.dll,

and Newtonsoft.Json.dll files.

http://help.abbyy.com/en-us/flexicapture/12/distributed_administrator/procserver
http://help.abbyy.com/en-us/flexicapture/12/distributed_administrator/procserver
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5. Save the Document Definition to apply the changes.

The next step is to create an export profiles.

FlexiCapture export profiles

ABBYY FlexiCapture exports data based on the export profiles in the Document Definitions. To configure

a usage scenario, you need to set up the corresponding export profile. There are two types of export

profile:

1. Standard XML export profile.

2. Script export profile to UiPath Orchestrator.

Standard XML export profile

1. Open the project on the Project Setup Station. 

2. Click Project→ Project properties→ General and make sure that Export root path field is

empty.

3. Then you need to configure the export profile. Open the list of document definitions in the project.

For the required document definition, open the Document Definition Editor, go to Export

settings, add the New export profile. Choose Type: Export to data files, enable Save

document images option if required. 
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4. Next, determine the conditions for applying your export profile. Select the option Errors are

irrelevant if you want to export both documents without rule errors, and documents with such

errors.

5. Select Target: Create folder structure and filename using template. Leave the Export path

field empty.

6. Specify a Template for naming export files (Template→ Edit→ View: Advanced→ use tags to

specify Filename template). Batch created by UiPath FlexiCapture Activity contains the

Registration Parameter FileNameWithoutExtension with the name of the source file. You can

specify Filename template: <RegParam: FileNameWithoutExtension> to use the name of the

source file for naming export files. You can also use any tags from the Tags list to specify the

Filename template.

7. Value of "If file exist" option is irrelevant in this case. Set Add suffix to name of new file.

8. Next, set the settings for the Data File Format. Select File type: XML Document (* .xml).

Note:  If the format of the export file is XML, then the activity will be able to get the array of document
fields. At this step, you can define the fields you want to export, and also specify the names for the fields.
To do this, click Set Up Field Mapping....

9. The next step is to select the option Save images with data. Select the Template of image file

names (Same as data, or specify a separate). If you want you can set the option Redact

sensitive data on images. 

10.Select the image file format. 

11.The last step is to set the name for the created export profile. After the new profile is created, you

need to check the Enabled flag for it.

12.Check the Critical flag for the profile to make it required for execution. Then you need to save the

changes in the document definition and publish its new version.

Additionally, you can configure any export format you need in FlexiCapture. For example, you can

choose to save the source file as a searchable PDF, export document data to other formats like XLS, or

save image fields containing signatures or stamps detected on the document. All of these exported files

will become available in UiPath.

Script export profile to UiPath Orchestrator

Before creating an export profile, make sure that the connector assemblies have been added to the

document definition.

In order to export the processing results from ABBYY FlexiCapture after verification (a long time after the

processing started), or if the image source is FlexiCapture Mobile Client or Scanning Station, you need

to configure the export using a script. The result of this export is the creation of a new transaction in a

particular Orchestrator queue. All processing results are stored in the transaction as strings in the

Specific Data.

To be able to export data from ABBYY FlexiCapture to UiPath via the Orchestrator web service, you

need to configure a script export profile in the Document Definition.

To create an export profile for UiPath, please do the following:
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1. On the Project Setup Station open your ABBYY FlexiCapture project.

2. Click Project → Document Definitions... to open the list of Document Definitions available for

the project, select the Document Definition for which you want to specify new export settings, and

click Edit....

3. Click Document Definition → Export Settings....

4. Click the Add... button to start the export profile creation wizard.

5. In the Select the Type of Destination step, select Custom export (script) from the Type drop-

down list. Leave the other settings unchanged or modify them as described in ABBYY

FlexiCapture Help. Click Next.

6. In the Script Export step, click the Edit Script... button, select Script Language: C# .Net, and

paste into the script editor one of the two sample scripts that are available in the Samples folder in

the UiPath Connector distribution package: UiPath - ExportScript - Configure by script

(Attended service).cs (please see Using a script to specify export settings for details) or UiPath

- ExportScript - Configure by XML (Attended service).cs (please see Using an XML file to

specify export settings for details). For a detailed description of the export options, see Specifying

export options.

7. In the Select the Destination Name step, specify a name for your export profile and click Finish.

8. The newly created export profile will appear in the list of available export profiles in the export

setup dialog box. To make ABBYY FlexiCapture use this profile on Export stage, select the box

next to the profile in the Enabled column.

9. Click OK and close the Document Definition editor. Next, click the Publish button to publish your

Document Definition.

Using an XML file to specify export settings

The advantage of using an XML file is that you don’t have to edit the script code or the Document

Definition. All modifications can be made by editing the XML file, which is much simpler than editing the

script code. However, the XML file should be located on every ABBYY FlexiCapture Processing Station.

And you will also have to synchronize it manually on all of the ABBYY FlexiCapture stations from which

data is to be exported to UiPath.

To specify export settings in an XML file:

1. Create an export script in the document definition that contains the sample script UiPath -

ExportScript - Configure by XML (Attended service).cs. This script gets the export settings

from the XML file.

2. Create such an XML file named <Project name>_<Document Definition name>.xml. This

naming scheme will allow you to have multiple XML files for different Document Definitions.

3. In the registry of the computer with ABBYY FlexiCapture Processing Station, locate

HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\12.0\Connectors\UiPath. Create

new string value and name it "XmlFolder". Then in its value data field specify the path to the folder

in which the XML file with export settings was created.
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4. In the registry of the computer with ABBYY FlexiCapture Processing Station, locate the

HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\12.0\Connectors\ and create new

string value and name it "UiPath". Set its value data field as true.

Note:  If you do not have the necessary keys in the HKEY_LOCAL_MACHINE \ SOFTWARE registry
branch, create them.

Note: As an example of a configuration XML file with detailed comments, please see
default.config.xml file that is located in the Sample folder in the ABBYY FlexiCapture Connector for
UiPath distribution package.

Note:  In the code of UiPath - ExportScript - Configure by XML (Attended service).cs, you can
also find some other possible naming schemes for your XML files.

Using a script to specify export settings

The advantage of using a script is that all the export settings will be automatically used by all the ABBYY

FlexiCapture stations from which data are exported to UiPath. When using an XML file, you can only

specify static settings, whereas scripts allow you to specify different file naming rules, file locations, and

field mappings depending on the data contained in the exported document.

When working with ABBYY FlexiCapture Cloud, you also need to use a script to specify export settings,

since ABBYY FlexiCapture Cloud does not provide the ability to store an XML file with configuration on

Processing Stations.

However, to modify the export settings, you will have to make changes to the script and, consequently,

publish a new version of the Document Definition.

Please use the script named UiPath - ExportScript - Configure by script (Attended service).cs

from the connector files.

Specifying export options

In the XML configuration file or in the script (depending on how you have chosen to configure your export

settings), you must specify the options that will be used for export. These include connection

parameters to be used to connect to UiPath Orchestrator, output image options, method of naming

export files, and field mapping.

1. UiPath Orchestrator connection settings.

1.1. In the Server option, specify the address of the server where Orchestrator is located.

· If you are using UiPath Enterprise Orchestrator, specify the Orchestrator web application's

address as the Server option like so:

connectorSettings.DmsConnectionSettings.Server = "https://orchestrator.mydomain.com";

· If you are using UiPath Cloud Platform Orchestrator, specify the following server address:

connectorSettings.DmsConnectionSettings.Server = "https://platform.uipath.com";

1.2. In the Repository option:

· If you are using UiPath Enterprise Orchestrator, specify the name of your Orchestrator

tenant.
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· If you are using UiPath Cloud Platform, specify your service name in your account like so:

connectorSettings.DmsConnectionSettings.Repository = "test_service";

You can find out the name of an available service by opening your UiPath Cloud Platform

account and navigating to the Services tab:

1.3. In the Username option:

· If you are using UiPath Enterprise Orchestrator, specify the name or the email of the

Orchestrator user.

· If you are using UiPath Cloud Platform, specify the user's email and authentication type in the

additional export option.

1.4. In the Password option specify the Orchestrator user's password.

Important! When using UiPath Cloud Platform with old accounts from UiPath Community
Orchestrator, you have to migrate it first to the new authentication method by resetting password.

The following roles should be assigned to a user in Orchestrator: view queues, create

transactions and view units.

https://forum.uipath.com/t/consuming-apis-with-the-new-cloud-orchestrator/123112
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2. In the FileName field, specify template, which will be used to generate the names of the export

files.

List of supported dynamically replaceable tags:

· <Project> – name of ABBYY FlexiCapture project;

· <Batch> – batch name;

· <DocumentDefinition> – name of document definition in ABBYY FlexiCapture;

· <Identifier> – document identifier;

· <BatchType> – batch type name;

· <Time> – current time in yyyy-MM-dd_HH-mm-ss format;

· <Index:> – Index field value.

Also, you can use the <FileNameWithoutExtension> tag to use the name of the source file (if

image was received from UiPath Activity, batch contains this Registration Parameter with name of

source image file).

3. In the field DmsMetadataTemplate.Name specify the Orchestrator queue name, for example:

connectorSettings.MappedFields.DmsMetadataTemplate.Name = "Verification queue"

After the export script is executed, a new transaction with data will be created in this queue. Create

such a queue in Orchestrator:

4. ExportImageSavingOptions - the options available for output images (e.g. image format options

or ability to redact fields containing confidential information) are described in ABBYY FlexiCapture

Help (look for the description of the IExportImageSavingOptions interface).

5. Map the fields in order to export recognized metadata. For each Document Definition field whose

value you want to export, you must specify its name in the transaction.

http://help.abbyy.com/en-us/flexicapture/12/developer/iexportimagesavingoptions


Snippet source Guide_header.xml not found!

Note:  Only those Document Definition fields will be exported to the transaction which have been
mapped. Any number of fields can be mapped.

If you configure export options using a script, the field pair must be in the following format:

{ @"Invoice Layout\InvoiceNumber", "InvoiceNumber" }

The first value is the full path to the field in the FlexiCapture Document Definition. The second value

is the name of the field in the UiPath Orchestrator transaction. In the second value, you can specify

the name that you want to use for the field in the transaction. Fields with the specified names will be

created in the transaction at runtime.

If you configure export options using XML, the field pair must be in the following format:

<FieldPair>

<AfcField>Invoice Layout\InvoiceNumber</AfcField>

<DmsField>InvoiceNumber</DmsField>

</FieldPair>

Where AfcField represents the full field name in the ABBYY FlexiCapture Document Definition, and

DmsField represents the field name in the UiPath Orchestrator transaction.

6. You can also specify additional UiPath export settings using the DmsSpecificOptions property:

6.1. AuthenticationType lets you choose the authentication type that will be used when logging in

to UiPath Orchestrator. It can have only 2 values: Basic and OAuth2.

Important! If you are setting up exporting to UiPath Cloud Platform Orchestrator, using this option is
required. In this case, specify it to be OAuth2.

If you are setting up exporting to UiPath Enterprise Orchestrator, specify the value to be Basic.

For UiPath Enterprise Orchestrator, using this oprion is not required.

A value for this option can be set using the following code:

connectorSettings.DmsSpecificOptions = new Option[] { 

new Option(new KeyValuePair<string, object>("AuthenticationType", "OAuth2"))

};

where AuthenticationType is the option name and the second attribute is the option value.

6.2. Reference lets you specify a reference when creating a transaction. To set up this option,

include the following piece of code in the export script:

connectorSettings.DmsSpecificOptions = new Option[] { 

new Option(new KeyValuePair<string, object>("Reference", Document.Batch.Id.ToString()))

};

where Reference is the option name and the second attribute is the option value. Specify 

Document.Batch.Id.ToString()as the value in order to use the batch identifier as a reference.

6.3. OrganizationUnitName lets you export processing results to the specified Orchestrator

Organization Unit. This option is available only for UiPath Enterprise Orchestrator.
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Note: in Orchestrator, the Organization Unit feature should be enabled.

To set this option up, include the following code in the export script:

connectorSettings.DmsSpecificOptions = new Option[] { 

new Option(new KeyValuePair<string, object>("OrganizationUnitName", "ORG_UNIT_NAME"))

};

where OrganizationUnitName is the option name and the second attribute is its value. Specify

the name of the Organization Unit that you want to set up as the option value.

6.4. AccountLogicalName lets you specify to which UiPath Cloud Platform account processing

results will be exported. This option is used if several UiPath Cloud Platform accounts are

available to the user. It is only available for UiPath Cloud Platform Orchestrator.

The account logical name is used as the value of this option. The logical name can be found in

the Orchestrator's Account Settings, it is the editable part of the Orchestrator site URL. The

logical name is also visible in the browser's address bar once you have logged in to your

account.

The sample code below illustrates the use of this option:

connectorSettings.DmsSpecificOptions = new Option[] { 

new Option(new KeyValuePair<string, object>("AccountLogicalName", "testaccount123"))

};

where AccountLogicalName is the option name and the second attribute is the option value.

https://orchestrator.uipath.com/docs/about-organization-units
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If you need to use several options in a single export script, list them as elements of the Option

array (separated by commas). For example:

connectorSettings.DmsSpecificOptions = new Option[] {

new Option(new KeyValuePair<string, object>("AuthenticationType", "OAuth2")),

new Option(new KeyValuePair<string, object>("AccountLogicalName", "ACCOUNT_LOGICAL_NAME")),

new Option(new KeyValuePair<string, object>("Reference", Document.Batch.Id.ToString()))

};

7. SaveDocumentImages option indicates whether image files should be saved to a UiPath

Orchestrator transaction. Set this option to true if images should be saved; set this option to false

if no images should be saved.

The sample code below illustrates the use of this option:

connectorSettings.SaveDocumentImages = true;

Note:  You can find examples of setting up export options in the [Connector installation path]
\Single-task package\Samples\FlexiCapture Scripts folder. Look for files named default.config.xml
and UiPath - ExportScript - Configure by script (Attended service).cs.

Receiving data from a transaction in the Orchestrator queue

The result of script export is the creation of a new transaction in a particular Orchestrator queue. 

All processing results are stored in the transaction as strings in Specific Data Items:

· DocumentDefinition name;

· BatchRegistrationParameters (Names and values);

· Fields (Names and values);

· Files (File names and file content as a base64 string).

Next, these strings need to be extracted and converted into a suitable data type.

Transaction Processing with the extraction of data from it must be carried out in the UiPath process. An

example of this process is included in the distribution package: ABBYY FlexiCapture 12 Receiver in

the Samples folder. Before launching the process, connect your Robot to Orchestrator, to which script

exporting from ABBYY FlexiCapture has been set up.

1. The process should receive the transaction from the queue (store it in a variable of type

QueueItem). The sample process will handle the first transaction having "New" status in the

queue. Launching the process once will process one transaction.

2. The process has been configured to display a window where you can select a folder into which to

save transaction data.

3. When a transaction is received, it is necessary to extract its rows and deserialize them into a

JSON object using the Deserialize json Activity. The JSON objects received for each of the

Specific Content Items must be stored in the variables of the following variable types: 

https://orchestrator.uipath.com/docs/connecting-robots-to-orchestrator
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· DocumentDefinition - String;

· BatchRegistrationParameters, Fields, Files - IEnumerable<KeyValuePair<string, string>>.

Then you can process the received data in any necessary way. The sample process saves them to

disk.

Note:  Before launching the process, specify the name of the queue from which to take a transaction.
Click the Get Transaction activity and on the Variables tab find the queueName variable. In the
Default field of this variable, specify the name of the queue from which to take a transaction.

You can launch the process from UiPath Studio, or you can publish the process to Orchestrator and use

a Robot to launch it.
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